Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
CahirInnershade - bug reporting and other info
Hi Lava,

It seems that the version number on Innershade download page indicates version 9.5 instead of 10.0 (download link redirects correctly to v10.0). Also, v10.0 archive seems to be missing in Dropbox repository.
Hi, Cahir! The download version flag is fixed now. I also uploaded the newest version of the mod to DropBox. Cheers! Wink
Well, I have an issue with Innershade and its main quest: I can't hurt 9XE1.

Reproducable behaviour: 

Watch out for the second half of the video; it is the second run... first run was with the interjection of Gahesh, so I avoided this in the second approach to minimize possible influence.

The quest variable is 4. Therefore the creature should be 9XE1. The actions of 9XE1 follow the script (protection spells, magic missile, ice storm). I hit the creature because I can see/read the slow effect from Brages weapon. But no damage at all even with critical hits. The creature itself should only have 60% resistance (regarding NI). I even don't get the message like: 0 damage or so. The only effect on the creature (in the file) is a blur effect. 

Via CLUA I created another 9XE1 which shows the same problems. 9XE2 somehow disappeared and 9XE3 I was able to kill. As they are all using the same script and dlg of course the game can't handle them all. 

Well I have no idea why 9XE1 has this kind of immunity. 

A direct comparison of 9XE1 vs  9XE3:
only the differences
HP:  130 vs 90 
Animation: static_boy vs ghast
Class: wraith vs spectre
Script name: 9XE1 vs 9XE3
Everything else is the same.

I played a bit with 9XE1: statistics with magic missiles: roughly 60% trigger a message of magic resistance and no effect for the other projectils. Therefore resistances seems to work.
Hmm, I have no idea why that would happen, it's been like... 10 years since the release? One thing comes to my mind... try changing his animation from boy to any other animation.
Well, that solved the issue. Looks like my local installation has an issue with certain animations. Funny enough I didn't use any specific mods like IA or 1pp...

And there is the next issue: when the third creature of 9XE is created, it disappears after the dialogue. And it doesn't matter, which one it is. Could be the third 9XE1 if I use CLUA. Or if the game runs now, it was 9XE3 which disappeared and ruined the script therefore. 

Looks like my installation it totally crap and I have no idea whiy Wink
I think that I once heard that some versions of the game blocked killing some animations - children, to be more precise. Not sure if that has anything to do with local law or what and I am not even sure if that's true!

As for disappearing: during that fight enemy divides itself into different creatures. You are supposed to find them on that area and kill them. Once all those "nightmare parts" are killed, a new version of the enemy appears and the battle continues. Perhaps it's that moment when you should find them? Check the area.
No, the nightmares are not the issue. It can be reproduced in any area by just creating creatures of 9XE-type. For example: create 9XE1, dialogue starts, spells are cast; create next 9XE1, dialogue starts, no spells (local variable is already set); create next 9XE1 dialogue starts, creature disappears. I tested this behavior 5 times (well only with 9XE1,2 and 3) but it doesn't matter in which order they are created or if I kill one of the previous ones or not. 

I finished the quest no matter, because I can CLUA the creatures afterwards. Only issue is that I have to adjust the main variable via CLUA.

And don't mind. I don't think that your mod is the issue. I suspect that just the large number of mods might be an issue or a specific mod that is altering effects (somewhere else) or a hick-up of a script during the conversion process of EET_end. Who knows...
Ideally, you should start from before entering that area, with child sprite changed to anything else, and then trying to do the quest without the console, so we knew nothing got messed up when you tried to fix it with console, but perhaps ignore it for now and I'll try to check it on the latest patch.

I kinda hope up it's not just my mods you're having problems with... huh... Anyway, I hope you're still having fun.
Hi Lava,

I am playing the TOB part of Innershade.
I saw there was an option to meet the creator of the dream when coming out of the Pocket Plane. But Since I was in a hurry to save Saradush, I decided to keep it for later.
Now the dialog option doen't trigger was I move out of the Pocket Plane. Do you have any idea how to solve the problem?
And do you still have a dialogue to determine where you want to teleport? There is a point when you can tell the Fate Spirit / Portal where you want to go, but if you no longer have access to that dialogue, then I guess it just won't work.
No I just get teleported to wherever I was before. I guess I missed it  Angry
To make it convenient I will probably add an option to get that dialogue reply just before the finale, but it's not there right now.
Well, you'll get something for the next run! You can imagine the creator does not deserve to meet her Dream she abandoned Wink

Forum Jump:

Users browsing this thread:
1 Guest(s)

Innershade - bug reporting and other info00