Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
RedSpoctoberJuniper Issue
Hello -

If I recall correctly, you don't use EET, which I am, so this may be an issue specifically with that 

If I put Juniper in my parry, i seem to get permanently stuck in Dialogue Mode. I can't save, Everything becomes very stutters, I am oddly able to talk to people.

Any ideas on what might be wrong?

It looks like she's starting to talk to you but she cannot start the dialogue due to some reason. Have you joined her during the initial talks? Before you faced Yaga-Shura? Or have you returned to her later? Does the problem start right after you join her?
I had the initial talk with her, then waited to bring her into the party until I got to Amkethran. The problems begin once she joins the party; I have not checked to see if they continue if I kick her out.
Ok, I have a feeling that this may be because of how EET handles dialogue and I never thought that this may cause any trouble with a ToB-only character. I wonder if it's happening because EET is trying to use her SoA talks and she has only ToB talks, even though in theory SoA are still set in pdialog.2da and interdia.2da. 

If you feel adventurous you may try to open pdialog (with Near Infinity) and change the line for L#JN to:


And then open interdia and change the line for L#JN to:


Is that going to explore your game? I... don't think so, BUT manual changes in such files mid-game is far from safe, in my opinion, so it all depends on the question of how badly you want to check it. Sorry, but I am unsure how the game is going to react to that. If you'd rather finish your game without that new character / quest, then that may be the best way to do it... Meanwhile, I will need to consult someone about this.
I think what I'll do Is create a manual save here, finish the game, and then come back and try this afterward, just in case it renders things unplayable.

I've played this run with almost all your quest mods and have loved them, so I'd love to check this one and eventually Bloodied Strings as well.

Thanks for your help!
Thank you! Meanwhile, I will also try to consult what may be improved to ensure better EET compatibility, if that's the reason for this to happen.
Where are the pdialog and interdia files located? The files in the Juniper Folder do not have the correct line. I tried changing the line in the files in the eet_end folder and the override folder, and neither changed the issue; changing the file in Override made things worse.
Those lines are added dynamically through tp2/install.tph, there are no such files in the mod itself. It looks like this will require another check on EET and I will consult this with another modder. I tried to make test version (available on the DropBox alternative download) BUT I cannot say if there is something else that must be addressed.

I am removing the EET tag on the download page until it's fixed.

Forum Jump:

Users browsing this thread:
1 Guest(s)

Juniper Issue00